Solved

Unable to add signup form to Wordpress

  • 22 December 2020
  • 2 replies
  • 141 views

Badge

I am new to Klaviyo and have created my first signup form, added my public API key to Wordpress page and got confirmation it was installed right.

I go to add my form code (<div class="klaviyo-form-xxxx"></div>) to a code block (I’m using Avada theme) and I get nothing. No form appears.

I tried adding it as a widget using the Wordpress plugin but that didn’t work either.

My form is Live but it won’t display.

Any advice would be great. 

icon

Best answer by ryang 23 December 2020, 16:37

Hi,

Sorry I should have updated my post.

It actually is working, I just couldn’t see it in my preview window. I opened up an incognito window and it was there as expected.

Thanks for the reply

View original

2 replies

Userlevel 5
Badge +3

Hi @ryang, are you still seeing an issue and did you first add Klaviyo.js to your Avada theme? 

To install Klaviyo signup forms on your site, first, copy the signup form code snippet below and update "Public API Key" with your Klaviyo Public API Key. Then, paste the updated snippet into your site's theme files.

This code block automatically populates line 3 with the Klaviyo public API key for the Klaviyo account you are currently logged in to. If you use multiple Klaviyo accounts, check that the correct public API key has been added to the code block. If you see "Public API Key", then your public API key has not loaded, and you'll have to manually update it. Copy your 6-character public API key from the Accounts > Settings > API Keys tab in your Klaviyo account.
mceclip0.png

<script type="text/javascript" async 
src="https://static.klaviyo.com/onsite/js/klaviyo.js?company_id=Public API Key"></script>

After updating this snippet with your Klaviyo public API key, paste it into the main theme file of your site, so that the code appears on every page. This allows you to trigger forms on any page on your site. The exact file and location where this code must be placed varies by ecommerce integration.

If you were able to troubleshoot, please let us know what ended up working for you. If not, feel free to follow up in this thread.

 

Badge

Hi,

Sorry I should have updated my post.

It actually is working, I just couldn’t see it in my preview window. I opened up an incognito window and it was there as expected.

Thanks for the reply

Reply