Question

Woocommerce - not accepting the correct shop url


Badge

Hello,

 

My woocommerce store is installed mydomain.com/shop, but when I use this URL in the WooCommerce Integrations Store URL, I get this error, “The Klaviyo extension is uninstalled or unavailable.”. However, if I just put the domain, mydomain.com, it finds it, and syncs the history to 75% and then fails. We are using the latest version of wordpress, hosted on siteground. I have disabled all caching and minify in attempts to troubleshoot. Any ideas?


4 replies

Userlevel 5
Badge +4

Hello @Jdub,

Thanks for sharing your question with the Klaviyo Community.

I would try removing the plug-in completely and re-running through the steps once again: https://help.klaviyo.com/hc/en-us/articles/115005255808-How-to-Integrate-with-WooCommerce#overview0 (including generating a new consumer secret and consumer key). If you have the exact same issue after running through these steps (getting stuck at 75%), we can take next steps from there. The store URL should be the same URL customers use to access your site.

Thanks and looking forward to hearing from you.

 

Badge

Hi,

 

I re-synced the history, and it seems to have completed. The woocommerce plugin is now showing green on the integrations tab. I see some past orders, but when I do the activity feed tests, I see nothing coming across. I even completed an entire woocommerce order and I don’t see anything new coming into Klavio. In addition, it won’t take the actual “shop” page. I have my home page, which is domain.com, and then woocommerce’s page is domain.com/shop/. If I put the shop domain in, it  says, “The Klaviyo extension is uninstalled or unavailable.”.

Userlevel 5
Badge +4

Hi @Jdub,

Thanks for your reply. Glad to hear the resync worked.

Klaviyo will run an initial sync to capture the last 90 days of data and then we’ll run another full historical sync as soon as the former completes to capture all remaining data. I recommend trying another order now that all of that data has likely finished syncing and let us know if you still do not see orders coming through in real time.

On your second point, the URL in the integration settings should just be your store URL (domain.com) without any additional path specified.

 

Badge

Hi,

I completed the “test” as per the documentation, and still nothing shows on the activity feed for woocommerce > Started Checkout. However, if I complete an entire checkout process, I see the order inside the activity feed under, “Placed Order”. It’s as if only some of the metrics are working for woocommerce.

 

The URL integration is confusing me, because the root domain, is NOT my store page. My homepage does not sell anything, its a blog. It’s not until you go to /shop, that is my store page. I’m sure its just semantics, but it is confusing.

Reply