Product Feed & Catalog Sources - Nothing is syncing

  • 19 November 2023
  • 5 replies

Badge +3

So I have seemed to run into something weird, where both my product feed and catalog sources aren’t syncing anything, I’ve tried deleting and re-creating to no avail. 


A few months ago, all products on my site were deleted. I decided to overlook my klaviyo settings and familiarize myself with recent changes, and came across every product/category was as if I never deleted anything off my shop. At this point I am really confused. Even re-creating API does not fix this. I have a bunch (hundreds...) of products and whatnot still showing up when they shouldn’t ( and - Every time I try to recreate a feed or source, it just tells me sync failed with no specification.  Both products showing up as published and not published, though absolutely none of the products that are in these feeds are no longer available on my site. I’m at the point, I need to ask for help. It worked before, nothing changed but the amount of products in my shop and now it’s not working at all. I am using wordpress+woocommerce. I feel like there is some things I missed on updates that this became a mess and I just don’t know how to fix it, because before it was pretty straightforward and simple, which doesn’t seem to be the case anymore. As far as everything else goes (campaigns and etc) I don’t seem to be running into any issues, just the integration now and making sure the products that are shown here are those shown on my website as well.


**Please PM for link as I need to take care of this matter before I can have it be live again.**


Best answer by TwoPointZero 30 November 2023, 02:00

View original

5 replies

Userlevel 7
Badge +35

Hi @TwoPointZero!

Can you confirm that all of the missing products are fully published on your e-commerce site? Also, do you mind telling me which version of WooCommerce you’re using?




Badge +3

Yes it is published, version 8.3.0 with wordpress v 6.4.1, php 8.0.3.


I literally have 1 product in my shop as of right now, so only 1 should be showing up.

Badge +3

I cannot find a way to 1) delete products or 2) delete categories and it shouldn’t be this complicated to get rid of data that is old and irrelevant. After doing another re-integration, I still am unable to get rid of any of the old data (items/categories) - how do I get rid of this?

Badge +3

Any sort of insight to a solution for this?

Badge +3

I guess one could assume the only way to fix this issue is paying for customer service to delete old content, which is something we should be allowed to do in our dashboard. Doesn’t make much sense that we have to pay for something like that. 


Go ahead and close this thread, their is no solution other than paying for them to delete old data.