Solved

Excel export show date instead of money value

  • 10 March 2022
  • 5 replies
  • 40 views

Userlevel 1
Badge +5
  • Active Contributor II
  • 16 replies

How can I solve segment exports. Some records show date instead of a money value. So 17,05 € is 17.feb. Is there a way to go around this?

icon

Best answer by alex.hong 10 March 2022, 23:07

View original

5 replies

Userlevel 7
Badge +58

Hi there @Iztok,

Thanks for sharing with the Community.

That is interesting behavior. Do you mind sharing an example of what appears vs what should be returned from your segment exports? Is it possible that your CSV has an incorrect format or mislabelled column that is causing this issue? 

 

Looking forward to hearing back,

Alex
 

Userlevel 1
Badge +5

Hi, Alex,

I just realized that when I rearange exported data (from one column) to various columns some of the ones that contain money values are turned into dates.

Not all of them, mind you.

So this:

| iztok.golob@gmail.com,12.75,26.11,12.75, |

becomes

iztok.golob@gmail.com | dec.75 | 26.nov | dec.75, 

 

It loks like it only happens with values from 1 - 12 (months). 

Do i need to format differently the original exported column first, before I spread it to various columns?

I looks like it is the excell issue. Not Klaviyo. But I would appreciate help regardless :).

Iztok

Userlevel 7
Badge +58

Hi @Iztok,

Thanks for the response with the example.

You’re correct that this is something going on within Excel’s side of the data importing.

Formatting the columns before moving them around would be helpful! This is of course assuming you’re manipulating data here and moving things around before/after. I would also suspect depending on the format of the column you set up, the column you are moving it in might be causing the issue as well.

One solution I think you can try is after exporting the data (before manipulation), copy and paste the data without formatting into a new sheet. Doing so would ensure that the entire sheet has 0 formatting so manipulating the data wouldn't cause any issues.

 

Hope this helped!
Alex

Userlevel 1
Badge +5

Hi, I think I figured it out. Thanks to you mentioning formating. What I did in the wizzard was setting each column from the “general” to “text” before finishing rearranging.

Hope all this makes sense. I use excell in my native language and I haven’t got a clue how all these excell options and funcionalities are called in English.

Thanks for you help. You did a lot.

Iztok

Userlevel 7
Badge +58

Hi @Iztok,

Glad to hear you figured it out and everything seems to be working!

Changing columns to text will do the job and you should be good to go now.

It could also have been that excel just wanted to automatically recognize that money value as date if it was in a similar enough format without any additional currency symbols.

 

Either way, glad we found a solution and I hope you have a great rest of your day!
Alex

Reply