Solved

Popup Form Not Triggering Welcome Automation

  • 21 February 2022
  • 4 replies
  • 62 views

Badge

Hello, my newsletter popup form is not triggering the linked Welcome series automation. I checked and double-opt in is turned off and the automation is connected to the newsletter list. Trying to solve this issue asap as it is live and we offer a discount for subscribing. Any ideas? Thanks

icon

Best answer by alex.hong 24 February 2022, 20:38

View original

4 replies

Hello, you have to get the form API to enable and validate flow to trigger. this can be done in different way 

  1. deleting the flows and resetting everything 
  2. Having the wrong segment selected as a trigger
  3.  Having testing the form by redrafting and their are more ways to fix this you can try this out 
Userlevel 7
Badge +57

Hi there @vgoods,

Welcome to the Community!
I think there could be different reasons why a customer would not see a popup form on your site or it is not triggering off a newsletter. Have you tested on an incognito browser after clearing your cookies and cache? Do you have an example of a user profile who signed up for a newsletter but did not see a form? 
Also if you can share your form settings + flow this could help diagnose the issue as well. I would recommend testing first and then coming back with more details as to what is going on.

 

Thank you!
Alex

Can you please tell me how you managed to resolve this as I am experiencing the same issue with the pop up not triggering the welcome series email.  Thanks

Userlevel 7
Badge +57

@Kalin ,

This would depend on some of the previous troubleshooting steps I had outlined. I would recommend trying those out and seeing first and testing on your own test profile and returning with results.

 

Reply