Solved

Flow trigger filters: "Has not been in this flow" is not appearing as an option

  • 3 September 2021
  • 2 replies
  • 49 views

Badge

I am setting up new flows and under trigger options, “Has not been in this flow” is not appearing as one of my filter options. 

Why would that be and how do I fix it?

Does that option only appear later after the list (which is also new) becomes populated with profiles? 

icon

Best answer by retention 3 September 2021, 19:55

View original

2 replies

Userlevel 7
Badge +5

@QuakerWildcat - Welcome to the community!  I suspect your Flow is a “List or Segment” triggered Flow?  If so, then List/Segment triggered Flows can only occur exactly once, so that’s why it’s not an option.

For Flows that are triggered by a Metric, then those have that option in the case that you want to limit how frequently (or at all) that they enter the Flow.  

For more information about the different types of Flow Triggers (List, Segments, Metric, or  Date), you can check out this article for more details: 

Hope this helps!

Userlevel 4
Badge +4

Hi @QuakerWildcat ,

 

Thanks for posting to the Community! I hope I can provide some insight into your question about flows and triggers.

Going off on @retention , this option is not available in list triggered flows because we have built-in logic that prevents a user from entering the flow more than once. 

Additionally, that option is not available in segment triggered flows either. But you can add the following condition to ensure that a user doesn't receive the flow a second time:

?name=inline-201389328.png

Hope this helped and thanks for being a part of the Community!

Alex

 

Reply