I have a password protected landing page on my Shopify store and my subscribers aren't being added to a list. What should I do?

  • 27 November 2020
  • 17 replies
  • 2390 views

Userlevel 4
Badge +3

This is likely happening due to your signup form not being configured properly to ensure that new signups get added to your list. There are two main steps to take to resolve this issue! The first will take place in your Klaviyo account and the second will take place from your Shopify Admin page. Ensure you’re logged into both for a speedy fix! 

  • Login to Klaviyo, navigate to the Integrations tab, and select your Shopify integration

From here, ensure that the “Subscribe customers who Accept Marketing to a Klaviyo list” check box is selected. If it isn’t, check this box and select the list you’d like subscribers added too. Be sure to click the Update Shopify Settings button when done.

 

  • Login to Shopify Admin and search for the password-content.liquid template within your store’s theme

When you find the page, look within that .liquid file for this code snippet:

<input type="hidden" name="contact[tags]" value="prospect, password page">​

 

You’ll need to update this snippet to include "newsletter" within the value section. It should end up looking like this:

<input type="hidden" name="contact[tags]" value="prospect, password page, newsletter">​

 

Once this has been updated, new subscribers will be correctly added to your Klaviyo account! Note that they will be added to the list you selected in your Shopify Integration Settings page (screenshot above). If you’ve done the above steps and are still experiencing issues with adding people to your main list in Klaviyo, reach out to our support team at success@klaviyo.com for assistance! 


17 replies

Hi @shoshana.antunes!

Thanks for the step-by-step description of the above issue. It has half-helped me so far: I have successfully selected the list I’d like subscribers added to and updated the Shopify Settings. That step seems to be all good. 

I’m using the Broadcast theme for oceanmeetsgreen.com. And have already had a few people subscribe via the password page. But they aren’t added to the selected list. 

But when trying to edit the code, I got stuck: In my Shopify Theme I can’t find the password-content.liquid template. I only see the password.liquid template, which doesn’t include the code snippet <input type="hidden" name="contact[tags]" value="prospect, password page">​

Have you got any tips on how to solve this issue?

Thank you :)

Alena

 

Userlevel 4
Badge +3

Hi @Alena I’m glad it was helpful!

Have you tried looking in other .liquid files within your Shopify theme? We don’t have a way to know for sure exactly what file this tag will be located in, since it can vary from theme to theme. If you do a command F (or control F if you’re on a PC!) and search for <input type="hidden" name="contact[tags]" in each liquid file you should be able to locate the correct code snippet and amend it as described in the post! This will ensure a double opt-in email is sent to the user so that they can subscribe to your designated list.

I hope this helps! :) 

Thank you so much @shoshana.antunes !

That helped a lot. I found it in the password.liquid file, located under the ‘Sections’ folder. And it worked :)

New subscribers now receive the email for the double opt-in. 

Have you got any tips how to make it work retrospectively (for the few users that already subscribed prior to making the above change) ?

Thank you!

 

Userlevel 7
Badge +48

Hello @Alena,

Thanks for that tip! Also, great question! 

Since the double opt-in confirmation email pertains to one’s consent, there would not be a way to retroactively send the double opt-in confirmation email to contacts who may have signed up prior to you updating the form settings. 

These contacts who signed up through the form would need to subscribe again in order to receive the double opt-in confirmation email to join your designated list. 

-David

Userlevel 4
Badge +3

Great, I’m glad to hear it @Alena ! 

 

Like @david.to mentioned, we can’t retroactively send double opt-in emails to people who previously subscribed. But there is the work around of creating a segment in Klaviyo of these people, then re-importing them into your list! Klaviyo will never create duplicate profiles so you don’t need to worry about the re-import causing any duplicates :)

 

The best way to make this segment is to use the Shopify tags that get attached to profiles who subscribed through your signup form:

  • Use the Properties About Someone definition in the segment builder > select Shopify Tags > then contains > prospect
  • Then add an AND connector and use Properties About Someone > select Shopify Tags > contains > password page
  • Add another AND connector and select If Someone Is or Is Not in a List > is not in list *name of your list they’re subscribing to*
  • Lastly, add a final AND connector and select If Someone Is or Is Not Suppressed > is not suppressed

Once you’ve created this segment, export it as a csv, then re-import the file to the list people are subscribing to! This will add these customers to your list, bypassing double opt in. 

 

Fun fact - you can also create a signup form targeted to only show to users in this segment asking them to subscribe again to emails. Once they re-subscribed, they would receive the double opt-in email again!

Once again, thank you very much @shoshana.antunes ! 

Creating the segment, exporting the contact and importing them to the list worked out very well :) And was super easy too.

 

Userlevel 4
Badge +3

Awesome @Alena ! We’re glad to hear it!

Thanks for solving the password protected landing page issues. I have found you from this interesting post ( mailchimp alternatives ) and subscribed to Klaviyo for trial and error email campaigns. I found your tools is interesting.

Userlevel 6
Badge +42

Hi @organikmonster

 

Happy to hear you’re enjoying our tools and Klaviyo experience so far! 

Here are some additional resources to gain more understanding of our product and the kind of Help documentation we offer: 

 

Hope you enjoy the Community and your experience with Klaviyo!

-Taylor  

Badge

@shoshana.antunes and others, thanks this is a useful thread. 

Since I am experiencing the same issues I tried to follow the above mentioned solutions. 
I have a password protected page (lexxcontacts.com) and I connected Klaviyo a while ago. Integration and sync are working, since I do see the new subscribers under ‘profiles’. My issue is that they aren’t showing in the newsletter list.

I did update the liquid code. Hopefully correct? See screen.
Any other advise you can give me? Many thanks! Wouter

 

Userlevel 4
Badge +3

Hi @wouter ! Based on your screenshot, everything seems to be in order. I am wondering whether people are not being added to your newsletter list due to double opt-in. If double opt-in is enabled for your newsletter list, people must first confirm they want to subscribe to emails from you before they are added to your list. It’s a great way to keep your newsletter list healthy by making sure only engaged subscribers get added!

 

You can confirm whether double opt-in in enabled by clicking into your newsletter list in Klaviyo, select settings, then scroll down until you see the opt-in process box. From this area, you can also enable single opt-in. If you choose to enable single opt-in instead, just make sure to clean your list regularly so that you’re getting rid of any contacts who aren’t engaging with your messaging! 

Badge

Hi @shoshana.antunes thanks for your reply! Appreciate it.

Yes, absolutely I’ve got double opt in activated and tested. I see that my customers are ‘subscribed’ when they confirm by clicking the confirmation email.  These profiles do end-up in Klaviyo like I wish, but aren’t added to the specific list… 
So I guess the issue is in other settings.

Userlevel 4
Badge +3

@wouter It’s great to hear that customers are being added to your Klaviyo account! 

 

If they’re going to a different list than you anticipated, this could be related to your Shopify integration settings. To double check what list your integration is sending subscribers to, navigate to the integrations tab of your account and click into your Shopify integration. You’ll see what list is selected under the Collect Subscribers section. Best to check that your newsletter list is selected under that drop down as this could be causing the issue :relaxed: 

Badge

Hi @shoshana.antunes thanks again. Yes, I did follow these steps, based on earlier recommendations and the basic set-up that needs to be done to integrate. I was hoping for a solution not mentioned earlier. The specific newsletter list is just not growing. Not sure how to solve this. I will talk to my developer next week, hope we find a solution.

Thanks!

 

Userlevel 6
Badge +42

Hey @wouter,

 

Thanks for confirming that your integration is properly synced to the right list! Users will only automatically be added to a Klaviyo list if they've confirmed their subscription through a Klaviyo double opt-in email. I think it might be worth checking out who the double opt-in message is coming from if your users who sign up are being added into your account, but not the right destination. Can you confirm that the message is a Klaviyo Double Opt-in message vs. a Shopify one? 

 

You can typically tell if the confirmation email was from Klaviyo if it's design matches the one from within your Klaviyo lists'. You can find how your Double opt-in email design looks like by navigating to Lists and Segments > List you were adding users to > Subscribe and Preference page > Confirmation email. 

 

If you can confirm that it’s coming from Shopify, I would disable the double-opt in in your Shopify settings as it could be overriding our Klaviyo opt-in. Once this is fixed, it should properly feed subscribers in to the right List, but I would test it on yourself first to see if you receive the right message after signing up. 

 

Hope this helps! 

-Taylor 

Badge

Thank you @Taylor Tarpley this is useful info. The emails are indeed from Shopify, not Klaviyo...you lead me to another important question...I am using a sign-up form from Shopify, not Klaviyo… I always thought that it would pass on the subscribers to Klaviyo and that it’s not per se needed to use the Klaviyo form. When I should use the Klaviyo form this solves the problem I guess…? That means we solved it. I will test this after the weekend. Thanks again for the adequate answers!!

Badge

Hi all, just wanted to get back to this topic, since it is solved. 
It was related to DNS settings. Unfortunately in our case the DNS verification didn’t go through or wasn’t approved. We did this again and it solved my problems as described above. So please check the DNS set-up instructions carefully.  Link

We still working with the Shopify newsletter sign-up form with Klaviyo double Opt in and all end up in the correct list. So I’m happy.

It also helped in the deliverability of test/preview emails to my Gmail account. 
Cheers, Wouter
 

Reply