Solved

Contact Form Submission Error: “An error occured when submitting. Please try again later.”

  • 21 June 2021
  • 6 replies
  • 843 views

Badge

Hi,


I have integrated Klaviyo with my Shopify and Gempages site, and I have a form now successfully showing up on one of my pages.

However, when I go to submit the form I get the following error:

“An error occured when submitting. Please try again later.”

I have gone through the help page and double checked that the button is a “submit” button and that the list it is submitting to exists.​​​​​​​

Any help would be much appreciated. 

icon

Best answer by Dov 30 July 2021, 15:02

View original

6 replies

Userlevel 6
Badge +5

Hi @Rhyder,

Thank you for your question.

Typically this error is due to a plug-in or another application linked to your browser, or a temporary error that will go away on its own. Can you try submitting the form in a net-new browser and see if you have the same issue?

If so, I recommend cloning the form, re-publishing it to your site and try testing it again.

Thanks and please do let us know if you’re still having trouble after this.

We are getting this error also. We’ve been running our form just fine for weeks, and all of a sudden getting this message. How can this be fixed?

Userlevel 6
Badge +5

Hello @ProducerConfidential,

Thank you for sharing this information with us.

In addition to the suggestion above:

Hi @Rhyder,

Thank you for your question.

Typically this error is due to a plug-in or another application linked to your browser, or a temporary error that will go away on its own. Can you try submitting the form in a net-new browser and see if you have the same issue?

If so, I recommend cloning the form, re-publishing it to your site and try testing it again.

Thanks and please do let us know if you’re still having trouble after this.

 

Could you please try the following steps and see if you still get the same error message?

Thanks for being a member of the Community. 

 

same message on my form, just installed it - url redirecting not working and form takes a LOT of time to show up - please help

Has this been marked as resolved? Is it a config error or a wider Klaviyo issue?

Userlevel 4
Badge +4

Hey @TheLastYuma 

Thank you for asking for clarity around this issue. As of now this looks like it is a configuration/communication issue between servers. Typically this can be solved by following the steps provided previously in this post. If you have tried all of these ideas and you are still experiencing the error, please contact Klaviyo Support as they will be able to look directly into your account and assess how to best solve the error for you and track the problem just in case there is a wider Klaviyo bug that needs attention.

Thank you again for being part of the Klaviyo Community!

Reply